游戏服务器_衢州建设网站_代金券

国际 虚拟云 浏览

小编:我们已经发布了新版本的sapcloudsdk。具体来说,新版本中提供了以下组件: 版本2.18.0中的Java库版本1.4.1中的JavaScript库v20版的持续交付工具包 在这篇博文中,我们将引导您了解这些版本

我们已经发布了新版本的sapcloudsdk。具体来说,新版本中提供了以下组件:

版本2.18.0中的Java库版本1.4.1中的JavaScript库v20版的持续交付工具包

在这篇博文中,我们将引导您了解这些版本的亮点。要获得完整的概述,请访问我们的Java库、JavaScript库和持续交付工具包的发行说明。发行说明还包括到目前为止我们所有发行版的更改日志。在文章的最后,您将看到一组关于如何更新到新版本的说明。

您可以将SAP Cloud SDK for Java的依赖项更新到2.18.0版本,并使用Maven Central的新版本。

将消息VDM更新到SAP S/4HANA Cloud 1905

在SAP S/4HANA Cloud最新版本1905之后,版本2.18.0更新了消息虚拟数据模型(VDM),高速云服务器,云服务器叫,该模型允许以类型安全的方式使用来自SAP S/4HANA云的消息。此更新包括30种新消息类型,以反映SAP S/4HANA Cloud中添加的新事件类型。因此,我们支持SAP S/4HANA云的所有业务事件类型。这些的Java表示可以从包中获得com.sap.cloud网站.sdk.s4版本hana.datamodel.messaging消息.api.消息.

进一步的改进

我们修复了Multichain模块中的一个问题,当结果包括未订阅的流时,listStreams中错误地抛出了一个异常。

进一步的改进在全文中列出发行说明。

SAP Cloud SDK的JavaScript库现已在版本1.4.1中提供。

OData client generator的发布

版本1.4.1带来了OData client generator for JavaScript和TypeScript的初始版本。正如sapcloudsdkforjava所知,生成器允许为定制OData服务生成客户端,从而简化从JavaScript或TypeScript访问OData服务的过程。generator的输出为开发人员提供了类似于SAP S/4HANA云OData服务的虚拟数据模型的体验,云主机的价格,但是用于定制OData v2服务。生成器在自己的模块@sap/cloud sdk generator中可用。

要使用生成器,请先将其安装到使用sap cloud sdk for JavaScript的项目中,如下所示:

然后,将有问题的OData v2服务的元数据文档存储在文件夹输入中,并调用生成器创建用于访问此OData服务的TypeScript文件:

有关详细信息,请查看使用说明和通过npx generate OData client--help提供的可用选项。

OData VDM的新教程系列

我们有发布了一个关于使用sapcloudsdkforjavascript的OData客户端的新教程系列。本系列教程使用了saps/4HANA Cloud中的业务合作伙伴服务示例,它是SDK中预交付的虚拟数据模型的一部分。这些概念也适用于使用上述生成器生成的任何客户机。

进一步的改进

版本1.4.1修复了一个问题,即带有协议HTTP(而不是HTTPS)的目的地导致了一个错误,如协议"HTTP:"不受支持。应为"https:".

我们还修复了一个问题,即由于链接实体之间的循环依赖性,点云数据建模,某些实体的反序列化将失败。这种循环依赖导致实体未定义,并导致错误消息,如无法读取未定义的属性"builder"。

与往常一样,完整的发行说明包含此版本中所有改进的列表。

我们还发布了现成的Jenkins服务器组成的开箱即用连续交付版本v20以及一个完整的交付工具包。

版本v20在Java上运行前端单元测试、Checkmarx和Fortify阶段,节点.js以及多目标应用程序的HTML5模块。

如果Checkmarx插件报告构建失败,管道现在中止构建,这样当Checkmarx实际可能有严重的发现时,管道运行不会被标记为成功。这对于阈值以上的项目来说是一个潜在的突破性变化。

您可以在完整的发行说明中找到进一步的修复和改进。

Java库

要更新现有项目中使用的SAP Cloud SDK Java库的版本,请按以下步骤进行:

打开pom.xml文件文件位于项目的根文件夹中。找到dependency management部分,大数据云平台,并在其中找到sdkbom依赖项。将该依赖项的版本更新为2.18.0.

这样,由于采用了"物料清单"(BOM)方法,您已经完成了。您的依赖关系应该是这样的:

如果您在SAP云应用程序编程模型的项目中使用SAP Cloud SDK,请将SDK bom替换为SDK modules bom,以仅更新SDK模块的版本,而不是进一步的依赖关系。现在,您可以重新编译您的项目(注意兼容性说明),并利用2.18.0版SAP Cloud SDK的新功能。

当然,通过运行Maven archetypefor Neo或Cloud Foundry的-DarchetypeVersion=2.18.0(或发行版),您还可以生成一个从一开始就使用版本2.18.0的新项目。

JavaScript库

要更新现有项目中使用的SAP Cloud SDK JavaScript库的版本,请在您的根文件夹中使用命令npm update模块。请注意,这还将更新其他模块,除非您明确指定要更新的包。如果您想事先检查将要更改的内容,请使用npm outloaded.

连续交付工具包

如果您使用的是固定版本的管道(从v7开始推荐),请使用在承载cx服务器的服务器上运行的以下命令更新连续交付工具包:

文章来源:www.vmchk.com

 
你可能喜欢的: